小希的迷宫(HDOJ-1272)

Problem Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0

-1 -1

Sample Output

Yes
Yes
No

Author

Gardon

Source

HDU 2006-4 Programming Contest

思路:

一道简单的并查集,只需要每次判断father结点是否相同,相同即为不行。
比较坑的地方就是要考虑自环和空树的情况。
看到discuss里有一个大神直接用|点| = |边| - 1判断,非常巧妙,一会儿去思考一下如何证明。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define MST(a, b) memset(a, b, sizeof a);
using namespace std;
typedef long long ll;
const int MAXN = 100000 + 100;
int fa[MAXN], u, v;
vector <int> maze;
int find_fa(int x) {
    return fa[x] == x ? fa[x] : fa[x] = find_fa(fa[x]);
}
void merge_fa(int x, int y) {
    int fx = find_fa(x), fy = find_fa(y);
    if (fx != fy) fa[fy] = fx;
}
int main() {
    while (cin >> u >> v) {
        if (u == -1 && v == -1) break;
        bool flag = true;
        if (u && v) {
            maze.clear();
            for (int i = 1; i <= 100000; i++) fa[i] = i;
            maze.push_back(u);
            maze.push_back(v);
            if (find_fa(u) == find_fa(v) && u != v) flag = false;
            else merge_fa(u, v);
            while (cin >> u >> v, u && v) {
                maze.push_back(u);
                maze.push_back(v);
                if (find_fa(u) == find_fa(v) && u != v) flag = false;
                else merge_fa(u, v);
            }
            for (int i = 0; i < maze.size(); i++)
                if (find_fa(maze[i]) != find_fa(maze[0])) {
                    flag = false;
                    break;
                }
        }
        if (flag) cout << "Yes" << endl;
        else cout << "No" << endl;
    }
}

猜你喜欢

转载自blog.csdn.net/white_yasha/article/details/80315991