HDU - 1312 Red and Black————搜索

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

这道题BFS和DFS都可以做的


BFS

#include<bits/stdc++.h>
using namespace std;
const int MAXN=50;
char str[MAXN][MAXN];
bool vis[MAXN][MAXN];
int n,m,ans,stx,sty,edx,edy;
int d[4][2]={0,1, 0,-1, 1,0, -1,0};
struct node{
    int x,y;
    node(){}
    node(int _x,int _y):x(_x),y(_y){}
};

void BFS(int x,int y)
{
    vis[x][y]=1;
    ans++;
    node e1=node(x,y);
    queue<node> que;
    que.push(e1);
    while(que.size())
    {
        node e2=que.front();
        que.pop();
        for(int i=0;i<4;i++)
        {
            int dx=e2.x+d[i][0];
            int dy=e2.y+d[i][1];
            if(dx>=0 && dx<n && dy>=0 && dy<m && !vis[dx][dy] && str[dx][dy]!='#')
            {
                ans++;
                vis[dx][dy]=1;
                que.push(node(dx,dy));
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d",&m,&n)&&(n|m))
    {
        memset(str,0,sizeof(str));
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)    scanf("%s",str[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                if(str[i][j]=='@')
                {
                    stx=i;
                    sty=j;
                    break;
                }
            }
        ans=0;
        BFS(stx,sty);
        printf("%d\n",ans);
    }
    return 0;
}

DFS

#include<bits/stdc++.h>
using namespace std;
const int MAXN=50;
char str[MAXN][MAXN];
bool vis[MAXN][MAXN];
int d[4][2]={1,0, -1,0, 0,1, 0,-1};
int n,m,ans;
int stx,sty,edx,edy;

void DFS(int x,int y)
{
    vis[x][y]=1;
    ans++;
    for(int i=0;i<4;i++)
    {
        int dx=x+d[i][0];
        int dy=y+d[i][1];
        if(dx>=0 && dy>=0 && dx<n && dy<m && !vis[dx][dy] && str[dx][dy]!='#')//判断条件不能搞错 
        {
            vis[dx][dy]=1;
            DFS(dx,dy);
        }
    }
}

int main()
{
    while(~scanf("%d %d",&m,&n)&&(n|m))
    {
        memset(str,0,sizeof(str));//不初始化 Wa 
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)    scanf("%s",str[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                if(str[i][j]=='@')//找到起点 
                {
                    stx=i;
                    sty=j;
                    break;
                }
            }
        ans=0;
        DFS(stx,sty);//从起点开始搜索 
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81428426