A - Number Sequence (KMP)

A - Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题意:

        给你一个文本串、模式串,求模式串在文本串中第一次出现的位置。两串从1 开始计数。

注意:

        模式串 和 文本串 要以 整数型数组 进行 查找。 用字符型会 错;

代码:

#include<map>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int ne[10005];
int mo[10005],text[1000005];      //以整数型存入
int lm,lt;
void nex()
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<lm)
    {
        while(j!=-1&&mo[j]!=mo[i])
            j=ne[j];
        ne[++i]=++j;
    }
}
int kmp()
{
    int i=0,j=0,ans=0,flag=-1;
    while(i<lt)
    {
        while(j!=-1&&mo[j]!=text[i])
            j=ne[j];
        i++,j++;
        if(j==lm)
          {
             flag=i-lm+1;
             return flag;
          }
    }
    return flag;
}
int main()
{
    int ca;
    scanf("%d",&ca);
    while(ca--)
    {
        int n,m,a,b;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&text[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&mo[i]);
        memset(ne,0,sizeof(ne));
        lm=m;
        lt=n;
        nex();
        printf("%d\n",kmp());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/team39/article/details/81074924