Number Sequence hdu 1711(kmp模板题)

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1

题意:找出在主串的第几位出现了模式串

题解:kmp模板题,见代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e4+10;
int a[N*100],b[N],net[N];
int m,n;
void getnext()
{
    int len=m;
    net[0]=-1;
    int k=-1,j=0;
    while(j<len)
    {
//        if(k==-1||b[j]==b[k])//未优化
//            net[++j]=++k;
        if(k==-1||b[j]==b[k])//优化
        {
            j++;
            k++;
            if(b[j]!=b[k]) net[j]=k;
            else net[j]=net[k];
        }
        else k=net[k];
    }
}
int kmp()
{
    int i=0,j=0;
    int lena=n,lenb=m;
    while(i<lena&&j<lenb)
    {
        if(j==-1||a[i]==b[j])
        {
            i++;
            j++;
        }
        else j=net[j];
    }
    if(j==lenb) return i-j+1;
    else return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&b[i]);
        getnext();
        printf("%d\n",kmp());
    }
}


猜你喜欢

转载自blog.csdn.net/never__give__up/article/details/80387730