【kmp】hdu 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 61666    Accepted Submission(s): 24685


 

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
 
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 
Sample Output
 
6 -1
 
Source
 
 
kmp模板
 
代码
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e6+5;
const int maxm=1e4+5;
int n,m,a[maxn],b[maxm],p[maxm];
void next()
{
	p[0]=-1;
	int i=0,j=-1;
	while(i<m) 
	{
		if(j==-1 || b[i]==b[j]) i++,j++,p[i]=j;
		else j=p[j];
	}
}
int kmp()
{
	int i=0,j=0;
	while(i<n && j<m)
	{
		if(j==-1 || a[i]==b[j]) i++,j++;
		else j=p[j];
	}
	if(j==m) return i-j+1;
	else return -1;
}
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	int t; scanf("%d",&t);
	while(t--)
	{
		memset(p,0,sizeof(p));
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++) scanf("%d",&a[i]);
		for(int i=0;i<m;i++) scanf("%d",&b[i]);
		next();
		printf("%d\n",kmp());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/andyc_03/article/details/110039528