hdu 1711 Number Sequence(KMP)

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

 思路:

     字符串匹配,使用kMP算法(详情见博客:https://mp.csdn.net/postedit

AC代码:

​
#include<stdio.h>
int a[1000001],b[10001],Next[100001];  //求Next数组
void getNext(int m)
{
    int i=0,j=-1;
    Next[0]=-1;
    while(i<m){
        if(j==-1||b[i]==b[j]){
            i++;j++;
            Next[i]=j;
        }
        else
            j=Next[j];
    }
    return ;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m,n;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int j=0;j<m;j++)
            scanf("%d",&b[j]);
        int k=0,s=0;
        getNext(m);
        while(k<n&&s<m)
        {
            if(a[k]==b[s]||s==-1){
                k++;s++;
            }
            else{
                s=Next[s];
            }
            if(s==m){
                printf("%d\n",k-s+1);
                break;
            }
        }
        if(s!=m)
            printf("-1\n");
    }
    return 0;
}

​

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1711

猜你喜欢

转载自blog.csdn.net/Krismile_/article/details/82814151