Number Sequence (KMP模板题)

Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题目大意:t组输入,n为母串的长度,m为子串的长度,求母串中首次出现子串的位置。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define  N 1000005
char S[N],T[N];
int nex[N],slen,tlen,a[N],b[N];
void getnext()
{
    int i=-1,j=0;
    nex[0]=-1;
    while(j<tlen)
    {
        if(i==-1||b[i]==b[j]) nex[++j]=++i;
        else i=nex[i];
    }
}
int KMP_index()
{
    int i=0,j=0;
    while(i<slen&&j<tlen)
    {
        if(j==-1||a[i]==b[j]) {i++;j++;}
        else j=nex[j];
    }
    if(j==tlen) return i-tlen+1;
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&slen,&tlen);
        for(int i=0;i<slen;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<tlen;i++)
            scanf("%d",&b[i]);
        memset(nex,0,sizeof(nex));
        getnext();
        printf("%d\n",KMP_index());
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/81476459