【HDU 1711】Number Sequence(KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36428    Accepted Submission(s): 15078


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
 
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
 
  
6 -1
 

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
#define MAXN 1000500
int s[MAXN];
int t[MAXN];
int n,m;
int nxt[MAXN];
void getnxt()
{
	int k,j;
	j=0;
	k=-1;
	nxt[0]=-1;
	while(j<m)
	{
		if(k==-1||t[j]==t[k])
		{
			nxt[++j]=++k;
		}
		else k=nxt[k];
	}
 }

int kmp()
{
	int i=0;
	int j=0;
	getnxt();
	while(i<n&&j<m)
	{
		if(j==-1||s[i]==t[j])
		{
			i++;
			j++;
		}
		else
		{
			j=nxt[j];
		}
	}
	if(j==m) return i-m+1;
	else return -1;
}
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
	int T;
	cin>>T;
	while(T--)
	{
		memset(nxt,0,sizeof(nxt));
		cin>>n>>m;
		for(int i=0;i<n;i++) cin>>s[i];
		for(int j=0;j<m;j++) cin>>t[j];
		cout<<kmp()<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/80641663