[KMP] A - Number Sequence HDU - 1711

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40427    Accepted Submission(s): 16672


 

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

扫描二维码关注公众号,回复: 3070664 查看本文章

 

Sample Input

 

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

 

Sample Output

 

6

-1

 

Source

HDU 2007-Spring Programming Contest

#include <bits/stdc++.h>
using namespace std;

const int mn = 1000010, mm = 10010;

int n, m;
int a[mn], b[mm];
int nx[mm];

void cal_next(int b[])
{
	nx[0] = -1;
	int k = -1;
	for (int i = 1; i <= m - 1; i++)
	{
		while (k > -1 && b[k + 1] != b[i])
			k = nx[k];
		if (b[k + 1] == b[i])
			k++;
		nx[i] = k;
	}
}

int KMP(int a[], int b[])   /// 在 a 中查找 b
{
	cal_next(b);
	int k = -1;
	for (int i = 0; i < n; i++)
	{
		while (k > -1 && b[k + 1] != a[i])
			k = nx[k];
		if (b[k + 1] == a[i])
			k++;
		if (k == m - 1)
		{
			return i - m + 2;
                // 可重叠继续寻找下一个则不return
                // 不可重叠则 k = -1;
		}
	}
	return -1;
}

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d %d", &n, &m);
		for (int i = 0; i < n; i++) // 数组从0开始
			scanf("%d", &a[i]);
		for (int i = 0; i < m; i++)
			scanf("%d", &b[i]);
		printf("%d\n", KMP(a, b));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81838100