【HDU 1711】Number Sequence(KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题目大意:你输入两个数列。去找第一个数列的子序列匹配第二个数列的第一个数的下标。

分析:直接KMP返回匹配到时的下标

不懂KMP算法的请百度学习,我的模板比较简单。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e6+5;

int NEXT_A[maxn];
int num_a[maxn];
int num_b[maxn];
int n;
int m;

void MakeNext( int *num ){
    int i = 0;
    int j = -1;
    NEXT_A[0] = -1;
    while( i < m ){
        if( j == -1 || num[j] == num[i] ){
            NEXT_A[++i] = ++j; 
        }
        else{
            j = NEXT_A[j];
        }
    }
}

int kmp(){
    int i = 0;
    int j = -1;
    int cnt = 0;
    while( i<n && j<m ){
        if( j == -1 || num_a[i] == num_b[j] ){
            i++;
            j++;
        }
        else{
            j = NEXT_A[j];
        }
        if( j == m ){
            cnt = i;
            cnt -= (m-1);
            return cnt;
        }
    }
    return -1;
}

int main(){
    int T;
    bool flag;
    scanf("%d",&T);
    while( T-- ){
        flag = true;
        scanf("%d%d",&n,&m);
        for( int i=0 ; i<n ; i++ ) scanf("%d",&num_a[i]);
        for( int i=0 ; i<m ; i++ ) scanf("%d",&num_b[i]);
        MakeNext(num_b);
        for( int i=0 ; i<m ; i++ ){
            if( num_a[i] != num_b[i] ){
                flag = false;
                break;
            }
        }
        if( flag ){
            puts("1");
        }
        else{
            int ans = kmp();
            printf("%d\n",ans);
        }
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/52196560