Number Sequence (KMP模板)

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

以后要写道题,写一篇博客

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1000006],b[1000006],pre[1000006];    int n,m;
void getpre()
{
    int i=0,j=-1;
    pre[0]=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            pre[++i]=++j;
        }
        else
            j=pre[j];
    }
}
int kmp()
{
    int i=0,j=0;
    int ans=0;
    getpre();
    while(i<n)
    {
        if(j==-1||a[i]==b[j])
        {
            i++;j++;
            if(j==m)
            {
            return i-j+1;
            }
        }
        else
            j=pre[j];
    }

    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {

        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(pre,0,sizeof(pre));

        scanf("%d %d",&n,&m);

        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int j=0;j<m;j++)
        scanf("%d",&b[j]);

        int sum=kmp();

        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liuliu2333/article/details/81806449