Number Sequence (KMP算法的模板题)

题目:https://vjudge.net/contest/243048#problem

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

直接套模板; 

#include <iostream>
#include <stdio.h>
#define maxn 1000005
#define maxm 10010
using namespace std;
int fail[maxm];
int str[maxn];
int temp[maxm];
void getFail(int n) {					//n表示短字符串的长度
  int i = 0, j = -1;						//i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;							//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])		//temp数组用来存储短字符串
		{
			++i, ++j;
			if(temp[i] != temp[j]) fail[i] = j;
			else fail[i] = fail[j];
		}
		else j = fail[j];
	}
}
int kmp(int n, int m) {				//n表示长字符串的长度,m表示短字符串的长度					//res表示长字符串中有多少个短字符串
	int i = 0, j = 0;					//i表示长字符串当前位置,j表示短字符串当前位置
	while(i < n) {
		if(str[i]==temp[j]) {	//temp存储短字符串,str存储长字符串
			if(j == m-1) {				//当发现长字符串中有一个短字符串时
				return i-j+1;
			}
				++i, ++j;
		}
		else
        {
            j = fail[j];
            if(j==-1){
                i++;j=0;
            }
        }
	}
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    int N,M;
    while(t--)
    {
        scanf("%d%d",&N,&M);
        for(int i=0;i<N;i++)
            scanf("%d",&str[i]);
            for(int i=0;i<M;i++)
                scanf("%d",&temp[i]);
                getFail(M);
               int ans= kmp(N,M);
               printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81359656