Number Sequence (KMP)

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1


题意:给定两个数组,问能不能在第一个数组中匹配得到第二个数组,如果可以,那么输出最早匹配的起始位置,否则输出-1。

简单的kmp问题,只需要在模板的基础上找到最早匹配的起始位置并输出即可。

#include<stdio.h>
#include<string.h>
int a[1000010],b[10010];
int n,m,next[10010];
void get_next()
{
	int i = 1, j = 0;
	while(i < m)
	{
		if(j == 0 && b[i] != b[j])
		{
			next[i] = 0;
			i ++;
		}
		else if(j > 0 && b[i] != b[j])
			j = next[j-1];
		else
		{
			next[i] = j + 1;
			i ++; j ++;
		}
	}
}
int kmp()
{
	int flag = 0,i = 0,j = 0;
	while(i < n && j < m)
	{
		if(j == 0 && a[i] != b[j])
			i ++;
		else if(j > 0 && a[i] != b[j])
			j = next[j-1];
		else
		{
			i ++; j ++;
		}
		if(j == m)
		{
			printf("%d\n",i - j +1);
			flag = 1;
		}
	}
	if(flag == 0)
		printf("-1\n");
}
int main()
{
	int i,t;
	scanf("%d",&t);
	while(t --)
	{
		scanf("%d%d",&n,&m);
		for(i = 0; i < n; i++)
			scanf("%d",&a[i]);
		for(i = 0; i < m; i++)
			scanf("%d",&b[i]);
		get_next();
		kmp();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81156749