kmp学习2 Number Sequence

题目描述

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

输入

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].输出For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

样例输入

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

样例输出

6
-1
经典kmp模板,题意求第二个字符在第一个字符中最早出现的位置。

#include<bits/stdc++.h>
#define ll long long
using namespace std;
const int N=1e6+10;
int ne[N];
int a[N],b[N];
int l1,l2;
void cal_ne(int b[]){        
 ne[1]=0;    
 int k=0;    
 for(int i=2;i<=l2;i++){        
 while(k&&b[k+1]!=b[i])       
 k=ne[k];       
 if(b[k+1]==b[i])      
 k++;       
  ne[i]=k;             
     } 
     }
 int kmp(int a[],int b[]){   
      int k=0;    
      for(int i=1;i<=l1;i++){       
       while(k&&b[k+1]!=a[i])       
        k=ne[k];       
        if(b[k+1]==a[i])       
        k++;       
        f(k==l2){            
         return  i-l2+1;            
              }    
             }    
           return -1;
         }
   int main() {   
          int t;   
           cin>>t;    
           while(t--){    
           cin>>l1>>l2;    
           for(int i=1;i<=l1;i++)    
           cin>>a[i];    
           for(int i=1;i<=l2;i++)    
           cin>>b[i];    
           cal_ne(b);   
            cout<<kmp(a,b)<<endl;
            } 
            }

猜你喜欢

转载自blog.csdn.net/Nefeertari/article/details/107762479