HDU-1711-Number Sequence(kmp)

                                                Number Sequence
 

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题意描述:

求母串包含子串时母串首字符的下标

程序代码:

#include<stdio.h>
#include<string.h>
void get_next();
int next[10010],n,m;
int a[1000010],b[10010];
int main()
{
	int T,i,j,count;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);	
		get_next();
		i=0;
		j=0;
		count=-1;
		while(i<n)
		{
			if(j==0&&a[i]!=b[j])
				i++;
			else if(j>0&&a[i]!=b[j])
				j=next[j-1];
			else
			{
				i++;
				j++;
			}
			if(j==m)
			{
				count=i-m+1;
				break;
			}
		}
		printf("%d\n",count);
	}
	return 0;
}
void get_next()
{
	int i,j;
	i=1;
	j=0;
	next[0]=0;
	while(i<m)
	{
		if(j==0&&b[i]!=b[j])
		{
			next[i]=0;
			i++;
		}
		else if(j>0&&b[i]!=b[j])
			j=next[j-1];
		else
		{
			next[i]=j+1;
			i++;
			j++;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81156781