Number Sequence (KMP模板)

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1
#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
const int maxn = 1e6+20;
int nxt[maxn];
int n,m;
int s[maxn];//母串 
int t[maxn];//子串
void getnxt()
{
	int i=1;
	int j=0;
	nxt[0]=0;
	while(i<m)
	{
		if(t[j]==t[i])
		{
			nxt[i++]=++j;
		}
		else if(!j)
		{
			i++;
		}
		else
		{
			j=nxt[j-1];
		}
	}
} 
int kmp()
{
	int i=0;
	int j=0;
	while(i<n&&j<m)
	{
		if(s[i]==t[j])
		{
			i++;
			j++;
		}
		else if(!j)
		{
			i++;
		}
		else
		{
			j=nxt[j-1];
		}
	}
	if(j==m) return i-m+1;
	else return -1;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&n,&m);
		for(int i=0;i<n;i++) scanf("%d",&s[i]);
		for(int i=0;i<m;i++) scanf("%d",&t[i]);
		getnxt();
		printf("%d\n",kmp());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42434171/article/details/81808109