Red and Black--(DFS)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

#include <stdio.h>
#include <cstring>
char a[22][22];
int b[22][22];
int fx[4][2]={1,0,-1,0,0,1,0,-1};
int ans;
void dfs(int x,int y,int p,int q)
{
    b[y][x]=1;                         /*把@点标记为1,即已走过*/
    for(int i=0;i<4;i++)
    {
        int x1=x+fx[i][0];
        int y1=y+fx[i][1];
        if(x1>=0 && x1<p && y1>=0 && y1<q && b[y1][x1]==0 && a[y1][x1]=='.')
        {
            ans++;
            b[y1][x1]=1;           /*把走过的点标记为1*/
            dfs(x1,y1,p,q);
        }
    }
}

int main()
{
    int w,h;
    while(scanf("%d%d",&w,&h) && w && h)
    {
        memset(b,0,sizeof(b));
        memset(a,0,sizeof(a));
        ans=1;
        for(int i=0;i<h;i++)
            scanf("%s",&a[i]);
        for(int i=0;i<h;i++)
        {
            for(int j=0;j<w;j++)
            {
                if(a[i][j]=='@') 
                {
                    dfs(j,i,w,h);                /*j是@点的横坐标,i是@点的纵坐标*/
                    printf("%d\n",ans);
                    break;
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/unikue/article/details/81326609