LightOJ - 1248

题目
Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * …))

= 2 + 0.5 + 0.52 + 0.53 + …

= 2 + 1 = 3

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output
For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

Sample Input
5

1

2

3

6

100

Sample Output
Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640
题目大意
有一个n面的骰子,求要掷多少次骰子才能看到它的所有面至少一次。
解题思路
数学期望(亦简称期望)是试验中每次可能结果的概率乘以其结果的总和。

设f[i]为看到骰子i个面所要掷的次数。
根据定义,可以得到

在这里插入图片描述
在这里插入图片描述
代码

#include <cstdio>
#include <iostream>
using namespace std;
double f[101010];
int num;
int main()
{
	int T;
	scanf("%d",&T);
	while (T--)
	{
		double n;
		cin>>n;
	    f[1]=1;
		for (int i=1;i<n;i++)
		  f[i+1]=f[i]+1+i/(n-double(i));
		printf("Case %d: %lf\n",++num,f[(int)n]); 
	}
}
发布了42 篇原创文章 · 获赞 0 · 访问量 605

猜你喜欢

转载自blog.csdn.net/weixin_45723759/article/details/103993420