LightOJ 1248 Dice (III)【数学期望--几何分布】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。<br> https://blog.csdn.net/sodacoco/article/details/89042456

参看资料:

http://www.cnblogs.com/zhengguiping--9876/p/5758993.html

https://baike.baidu.com/item/几何分布/10676983?fr=aladdin


题目:

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

Sample Input

5

1

2

3

6

100

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640

题目大意: 

       有一个 n 面的骰子,问使 n 个面都至少出现一次的 投掷次数的 期望。

解题思路:

       1》看懂题了之后,懵*,每个面都至少出现一次,我要投几次?

       那就是要求,第一个面出现的概率,和它对应值--投掷了几次,然后求第二个面出现的概率,还有为了投出第二个面,投掷的次数。。。懵* x 2。

       2》查资料,几何分布。恩???几何分布???几何分布是什么来着我先查一下下。。

       

      3》对于任意一次来说好像还真的是酱婶的,但是这是求所有的面啊,各个面之间没有影响吗?为什么是几何分布??懵* x 3

      4》嗷。。这个题要求是 让n 个面都出现一次,并没有说有顺序要求,所以各个面之间的差异就只是“第几个面”,谁先出现谁就挨号,没有顺序之差。 并且!对于几何分布来说,本来就是每一次投掷都等同于第一次投掷,各个面出现的概率相同,so...我们只需要搞明白各个面第一次出现的概率即阔:

          第一个面 第一次出现的概率是p1 n/n;

          第二个面 第一次出现的概率是p2 (n-1)/n;

          第三个面 第一次出现的概率是p3 (n-2)/n;

          ...

          第 i 个面 第一次出现的概率是pi (n-i+1)/n;

       5》几何分布的期望E(X) = 1/p【公式】;

            且几何分布是一个离散型的分布:

            

            可以得到:所求期望为∑ 1/pi  = n * (1+1/2+1/3+1/4+1/5+...+1/n);

实现代码:

#include<cstdio>
#define N 105
using namespace std;

int main(){
    int n,T,t=1;
    scanf("%d",&T);

    while(T--){
        scanf("%d",&n);
        double sum=0;
        for(int i=1;i<=n;i++)
            sum+=1.0/i;
        printf("Case %d: %.6f\n",t++,sum*n);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/89042456