LightOJ - 1125

LightOJ - 1125

Given a list of N numbers you will be allowed to choose any M of them. So you can choose in NCM ways. You will have to determine how many of these chosen groups have a sum, which is divisible by D.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

The first line of each case contains two integers N (0 < N ≤ 200) and Q (0 < Q ≤ 10). Here N indicates how many numbers are there and Q is the total number of queries. Each of the next N lines contains one 32 bit signed integer. The queries will have to be answered based on these N numbers. Each of the next Q lines contains two integers D (0 < D ≤ 20) and M (0 < M ≤ 10).

Output

For each case, print the case number in a line. Then for each query, print the number of desired groups in a single line.

Sample Input

2

10 2

1

2

3

4

5

6

7

8

9

10

5 1

5 2

5 1

2

3

4

5

6

6 2

Sample Output

Case 1:

2

9

Case 2:

1

#include<iostream>
#include<stdio.h>
#include<cstring>
#define ll long long 
using namespace std;
ll dp[15][20];//dp[j][k]表示选了j个数,余数为k的情况
int num[205];
int main()
{
	int t,cnt=0;;
	scanf("%d",&t);
	while(t--)
	{
		int n,q;
		scanf("%d%d",&n,&q);
		for(int i=1;i<=n;i++)
		scanf("%d",&num[i]);
		int d,m;
		printf("Case %d:\n",++cnt);
		while(q--)
		{
			scanf("%d%d",&d,&m);
			memset(dp,0,sizeof(dp));
			dp[0][0]=1;//取0个数余数为0就只有一种情况
			for(int i=1;i<=n;i++)
			{
				for(int j=m;j>=1;j--)
				{
					int tmp=num[i]%d;
					for(int k=0;k<d;k++)
					{
						dp[j][k]+=dp[j-1][(k-tmp+d)%d];//要加d,避免出现负数
					}
				}
			}
			printf("%lld\n",dp[m][0]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40942372/article/details/80009820