LightOJ - 1030

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

1

101

2

10 3

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

大概题意:就是每点有一定的黄金数量,然后每次摇骰子,到该点加上骰子数的那个点,超过n,则重新摇,求在起始点到最后点得到的黄金数量的期望。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MaxN = 100;
double dp[MaxN + 5]; // 在i点得到黄金数量的期望
int T, n, Case;

int main()
{
    scanf("%d", &T);
    while(T--)
	{
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) 
			scanf("%lf", &dp[i]);
        for(int i = n - 1; i >= 1; i--)
		{
            double tot = 0;
            int cnt = min(6, n - i);
            for(int j = i + 1; j <= i + cnt; j++) 
				tot += dp[j]; // 算不超过n的点
            dp[i] += tot / cnt; // 走到每点的概率都是一样的
        }
        printf("Case %d: %lf\n", ++Case, dp[1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38295645/article/details/80468198