期望——J - Dice (III) LightOJ - 1248

博客目录

返回二级目录——kaugnbin概率dp习题集

原题

题目传送门

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

Sample Input

5

1

2

3

6

100

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640

题目大意

大致题意:给你一个n面的骰子,每一次你所能甩到的每个面的概率都一样,问你将所有的面都能甩到一次的概率期望是多少。

思路

假设此时的骰子有n面,dp[i]表示此时已经甩出i个不同面的概率期望,dp[1]=1. 
状态转移方程即为:dp[i]=(i-1)/n*dp[i-1]+(n-i+1)/n*dp[i]+1; 
化简得:dp[i]=dp[i-1]+n/(i-1);最后答案即为dp[n]

AC代码

#include<bits/stdc++.h>
using namespace std;
int const maxn=1e5+10;
double dp[maxn];
int main()
{
    int T;
    cin>>T;
    int n,i,j;
    int cs=1;
    while(T--)
    {
        cin>>n;
        for(i=0;i<=n;i++)
            dp[i]=0;
        for(i=n-1;i>=0;i--)
        {
            dp[i]=(n-i)*dp[i+1]+n;
            dp[i]/=n-i;
        }
        printf("Case %d: %.10f\n",cs++,dp[0]);        
    }
}

猜你喜欢

转载自blog.csdn.net/GreyBtfly/article/details/82501433