loj 1248

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

Sample Input

5

1

2

3

6

100

Sample Output

Case 1: 1

故设dp[i]为在已经扔出了i个不同面的情况下扔出n个不同面的期望次数,dp[n]=0,答案为dp[0]
dp[i]=dp[i]in+dp[i+1]nin+1dp[i]=dp[i]∗in+dp[i+1]∗n−in+1

移项得:dp[i]=dp[i+1]+nni

至今直接仍然不明白为什么是n/n-i,后来还是觉得要看状态转移方程,其中1和后面的一个式子是好理解的,第二个式子则是表明保持原装态不变,这才是需要理解的。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define N 100010

int main()
{
    int T,n,iCase=1;
    double dp[N];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        dp[n]=0;
        for(int i=n-1;i>=0;i--) dp[i]=dp[i+1]+n*1.0/(n-i);
        printf("Case %d: %.7f\n",iCase++,dp[0]);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/coolwx/p/11421572.html