LightOJ 1002

I am going to my home. There are many cities and many bi-directional roads between them. The cities are numbered from0 to n-1 and each road has a cost. There are m roads. You are given the number of my city t where I belong. Now from each city you have to find the minimum cost to go to my city. The cost is defined by the cost of the maximum road you have used to go to my city.

For example, in the above picture, if we want to go from 0 to 4, then we can choose

1)      0 - 1 - 4 which costs 8, as 8 (1 - 4) is the maximum road we used

2)      0 - 2 - 4 which costs 9, as 9 (0 - 2) is the maximum road we used

3)      0 - 3 - 4 which costs 7, as 7 (3 - 4) is the maximum road we used

So, our result is 7, as we can use 0 - 3 - 4.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a blank line and two integers n (1 ≤ n ≤ 500) and m (0 ≤ m ≤ 16000). The next m lines, each will contain three integers u, v, w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 20000) indicating that there is a road between u and v with cost w. Then there will be a single integer t (0 ≤ t < n). There can be multiple roads between two cities.

Output

For each case, print the case number first. Then for all the cities (from 0 to n-1) you have to print the cost. If there is no such path, print 'Impossible'.

Sample Input

2

5 6

0 1 5

0 1 4

2 1 3

3 0 7

3 4 6

3 1 8

1

5 4

0 1 5

0 1 4

2 1 3

3 4 7

1

Sample Output

Case 1:

4

0

3

7

7

Case 2:

4

0

3

Impossible

Impossible

Note

Dataset is huge, user faster I/O methods.

题目大意:有n个城市,m条路,求出每条到终点的路的最大权值;

 Dijkstra's的变形;

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
    int T,N=0;
    scanf("%d",&T);
    while(T--)
    {
        int e[505][505],dis[505],mark[505];
        int t,m,n,i,j,a,b,l;
        memset(e,inf,sizeof(e));
        memset(mark,0,sizeof(mark));
        scanf("%d %d",&n,&m);
        for(i=0; i<m; i++)
        {
            scanf("%d %d %d",&a,&b,&l);
            e[a][b]=min(l,e[a][b]);
            e[b][a]=min(l,e[b][a]);
        }
        scanf("%d",&t);
        for(i=0; i<n; i++)
            dis[i]=e[t][i];
        mark[t]=1;
        dis[t]=0;
        for(i=1; i<n-1; i++)
        {
            int mini=inf;
            for(j=0; j<n; j++)
            {
                if(mark[j]==0&&dis[j]<mini)
                {
                    t=j;
                    mini=dis[j];
                }
            }
            mark[t]=1;
            for(j=0; j<n; j++)
            {
                if(mark[j]==0&&dis[j]>max(dis[t],e[t][j]))
                    dis[j]=max(dis[t],e[t][j]);
            }
        }
        printf("Case %d:\n",++N);
        for(i=0; i<n; i++)
        {
            if(dis[i]==inf)
                printf("Impossible\n");
            else
                printf("%d\n",dis[i]);
        }
    }
}


猜你喜欢

转载自blog.csdn.net/qq_41984014/article/details/80015251