Dice (III) LightOJ - 1248

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

Sample Input

5

1

2

3

6

100

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640

思路1:

又是抛筛子,设dp[i+1]表示有i+1个面时的期望,那么dp[i+1]=dp[i+1]*(i/n)+dp[i]*(n-i)/n+1

意思是dp[i+1]可能由dp[i]*剩下的n-i个中选一个的概率转移过来,也可能由dp[i+1]本身转移过来。

这也是概率dp与普通dp的不同之处,它只进行动态,不“规划”。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
#define inf 0x3f3f3f3f
int n;
double dp[maxn];
int main(int argc, char const *argv[])
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    int T;
    int Case=0;
    cin>>T;
    while(T--)
    {
        scanf("%d",&n);
        dp[0]=0;
        for(int i=0;i<n;i++)
        {
            dp[i+1]=1.0*dp[i]+1.0*n/(n-i);
        }
        printf("Case %d: %.7lf\n",++Case,dp[n]);
    }
    return 0;
}

思路2:数学思想解决

第一个面第一次出现的概率是p1 n/n;

第二个面第一次出现的概率是p2 (n-1)/n;

第三个面第一次出现的概率是p3 (n-2)/n;

...

第 i 个面第一次出现的概率是pi (n-i+1)/n;

先看一下什么是几何分布:

几何分布: 在第n次伯努利试验中,试验 次才得到第一次成功的机率为p。详细的说是:前k-1次皆失败,第k次成功的概率为p。

几何分布的期望E(X) = 1/p;

所以所求期望为∑1/pi = n * (1+1/2+1/3+1/4+1/5+...+1/n);

猜你喜欢

转载自blog.csdn.net/qq_40774175/article/details/81487903