UVA-562.Dividing coins(特殊的背包,如何选能使差值最小)

UVA-562.Dividing coins

It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over
a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce,
they stretched the coin to great length and thus created copper-wire.
Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with
coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch
of the past couldn’t stand the fact that a division should favour one of them and they always wanted
a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but
being capable of making an equal division as fair as possible is something that will remain important
forever…
That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s the
most fair division of a bag of coins between two persons. Your help is asked to solve this problem.
Given a bag with a maximum of 100 coins, determine the most fair division between two persons.
This means that the difference between the amount each person obtains should be minimised. The
value of a coin varies from 1 cent to 500 cents. It’s not allowed to split a single coin.
Input
A line with the number of problems n, followed by n times:
• a line with a non negative integer m (m ≤ 100) indicating the number of coins in the bag
• a line with m numbers separated by one space, each number indicates the value of a coin.
Output
The output consists of n lines. Each line contains the minimal positive difference between the amount
the two persons obtain when they divide the coins from the corresponding bag.
Sample Input
2
3
2 3 5
4
1 2 4 6
Sample Output
0
1
题目大意是:给你m个数字,让你分成两组,使得其差值最小,并且输出差值。
思路:是突然蹦出来的,突然想到让总和sum/2当最大的V,然后输出V-2*f[sum/2]就可以了,试了一下还真对了。

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
using namespace std;
typedef long long ll;
int v[1005],w[1005],f[50005];
int main()
{
	int t,n;
	cin>>t;
	while(t--)
    {
        int sum=0;
        cin>>n;
        for (int i=1;i<=n;i++)
        {
            cin>>v[i];
            sum+=v[i];
        }
        memset(f,0,sizeof(f));
        for (int i=1;i<=n;i++)
            for (int j=sum/2;j>=v[i];j--)
                f[j]=max(f[j],f[j-v[i]]+v[i]);
        cout<<sum-2*f[sum/2]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43892298/article/details/87922398
今日推荐