R - Dividing 多重背包

来源poj1059

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be 0 0 0 0 0 0''; do not process this line. ##Output For each colletcion, outputCollection #k:'', where k is the number of the test case, and then either Can be divided.'' orCan't be divided.''.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

把让你分成两堆价值相同的石子,把他的价值也当做消耗去做

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define scf(x) scanf("%d",&x)
#define scff(x,y) scanf("%d%d",&x,&y)
#define prf(x) printf("%d\n",x) 
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+7;
const double eps=1e-8;
const int inf=0x3f3f3f3f;
using namespace std;
const double pi=acos(-1.0);
const int N=5e5+10;
int dp[N];
int num[7];
int main()
{
    int cas=1;
    while(1)
    {
        int sum=0;
        rep(i,1,7)
        {
            scf(num[i]);
            sum+=i*num[i];
        }
        if(sum==0) return 0;
        if(sum&1)
        {
            pf("Collection #%d:\nCan't be divided.\n\n",cas++); continue;
        }
        sum/=2;
        int cnt=0;
        mm(dp,0);
        dp[0]=1;
        rep(i,1,7)
        {
            if(!num[i]) continue;
            for(int j=1;j<=num[i];j*=2)//二进制优化 
            {
                num[i]-=j;
                int ans=j*i;
                per(k,sum,ans)
                    if(dp[k-ans])
                     dp[k]=1; 
            }
            int ans=num[i]*i;
            if(ans)
                per(j,sum,ans)
                    if(dp[j-ans])
                        dp[j]=1;
        }
        if(dp[sum])
        pf("Collection #%d:\nCan be divided.\n\n",cas++);
        else
        pf("Collection #%d:\nCan't be divided.\n\n",cas++);
    }
}
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define scf(x) scanf("%d",&x)
#define scff(x,y) scanf("%d%d",&x,&y)
#define prf(x) printf("%d\n",x) 
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+7;
const double eps=1e-8;
const int inf=0x3f3f3f3f;
using namespace std;
const double pi=acos(-1.0);
const int N=5e5+10;
int dp[N];
int tot;
int num[7];
void bag01(int cost,int val)
{
    per(i,tot,cost)
        dp[i]=max(dp[i],dp[i-cost]+val);
}
void bagall(int cost,int val)
{
    rep(i,cost,tot+1)
        dp[i]=max(dp[i],dp[i-cost]+val);
}
void multbag(int cost,int val,int n)
{
    if(cost*n>tot)
    {
        bagall(cost,val);
        return;
    }
    int k=1;
    while(k<n)
    {
        n-=k;
        bag01(k*cost,k*val);
        k*=2;
    }
    bag01(n*cost,n*val);
}
int main()
{
    int cas=1;
    while(1)
    {
        tot=0;
        rep(i,1,7)
        {
            scf(num[i]);
            tot+=i*num[i];
        }
        if(tot==0) return 0;
        if(tot&1)
        {
            pf("Collection #%d:\nCan't be divided.\n\n",cas++); continue;
        }
        tot/=2;
        mm(dp,0);
        rep(i,1,7)
        {
            if(!num[i]) continue;
            multbag(i,i,num[i]);
        }
        if(tot==dp[tot])
        pf("Collection #%d:\nCan be divided.\n\n",cas++);
        else
        pf("Collection #%d:\nCan't be divided.\n\n",cas++);
    }
}

猜你喜欢

转载自www.cnblogs.com/wzl19981116/p/9492607.html