HDU 1059 - Dividing【多重背包】

多重背包之二进制优化

题目描述:
Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line 1 0 1 2 0 0’’. The maximum total number of marbles will be 20000.
The last line of the input file will be 0 0 0 0 0 0’’; do not process this line.
Output
For each colletcion, output Collection #k:’’, where k is the number of the test case, and then either Can be divided.’’ or ``Can’t be divided.’’.
Output a blank line after each test case.

Sample Input
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
Sample Output
Collection #1: Can’t be divided.
Collection #2: Can be divided.

思路解法:
他用普通的多重背包会超时,故必须要使用二进制优化。
二进制优化就是用分割的思想,将c[i]件物品,拆成价值不等,大小不等的几份物品。本题呢又是只有价值,没有体积的题目。故每次更新价值的值就可以了,把v[i]拆分成几个val[i]。
分割代码如下:

for(int i=1;i<=6;i++){
        	res=1;
        	while(1){
        		if(res>=c[i]){
        			val[td++]=c[i]*v[i];
        			break;
				}
				else{
					c[i]-=res;
					val[td++]=res*v[i];
				}
				res<<=1;
			}
		}

完整代码如下:

#include<bits/stdc++.h>
using namespace std;
#define N 300005
const int inf=0x3f3f3f3f;
int v[]={0,1,2,3,4,5,6};
int dp[N],c[N],res=1,val[N],td;
int main(){
    int t=0,sum=0;
    while(cin>>c[1]>>c[2]>>c[3]>>c[4]>>c[5]>>c[6]){
    	td=0;
        t++;
        if(c[1]==0&&c[2]==0&&c[3]==0&&c[4]==0&&c[5]==0&&c[6]==0) return 0;
        sum=0;
        memset(dp,0,sizeof dp);
        for(int i=1;i<=6;i++) sum+=c[i]*v[i];
        for(int i=1;i<=6;i++){
        	res=1;
        	while(1){
        		if(res>=c[i]){
        			val[td++]=c[i]*v[i];
        			break;
				}
				else{
					c[i]-=res;
					val[td++]=res*v[i];
				}
				res<<=1;
			}
		}
		for(int i=0;i<td;i++){
			for(int j=sum/2;j>=val[i];j--){
				dp[j]=max(dp[j],dp[j-val[i]]+val[i]);
			}
		}
        cout<<"Collection #"<<t<<":\n";
        if(dp[sum/2]*2==sum) cout<<"Can be divided.\n";
        else cout<<"Can't be divided.\n";
        cout<<endl;
    }
    return 0;
}

发布了43 篇原创文章 · 获赞 56 · 访问量 5142

猜你喜欢

转载自blog.csdn.net/tran_sient/article/details/94918123