Dividing coins 【01背包】

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input 

A line with the number of problems n, followed by n times:

  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1

题目大意:给你一组硬币每种硬币只有一个,把这些硬币分给两个人是这两个人最后硬币数量总和的差最小。 

大致思路:我们可以把所有硬币平均分成两半,然后转化为01背包问题,求解每一半所能获得的最大值,最后在用减去其二倍即可。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=100010;
int a[MAXN],dp[MAXN];
int main(){
	int t,n;
	cin>>t;
	while(t--){
		cin>>n;
		int sum=0;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){
			cin>>a[i];
			sum=sum+a[i];
		}
		int ans=sum/2;
		for(int i=1;i<=n;i++){
			for(int j=ans;j>=a[i];j--){
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
			}
		}
		//cout<<sum-2*dp[n]<<endl;此处的dp表示的是背包分成来那个人之后所能盛放的最大价值
		cout<<sum-2*dp[ans]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/81592395
今日推荐