Dividing 多重背包问题

Dividing

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 13   Accepted Submission(s) : 5

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

Mid-Central European Regional Contest 1999 

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define max(x,y) x>y?x:y
int dp[120100], total;
void zero_one_pack(int w, int v) {
	for(int i = total; i >= w; i--) {
		dp[i] = max(dp[i], dp[i-w]+v);
	}
}
void complete_pack(int w, int v) {
	for(int i = w; i <= total; i++) {
		dp[i] = max(dp[i],dp[i-w]+v);
	}
}
void multi_pack(int w, int v, int n) {
	int  k, amount;
	if(w*n>=total) {
		complete_pack(w,v);
	} else {
			amount = n;
			k = 1;
			while(k <= amount) {
				amount -= k;
				zero_one_pack(k*w,k*v);
				k <<= 1;
			}
			zero_one_pack(amount*w,amount*v);		
	}
}
int main() {
	int a[10], n, sum, i, j, flag;
	n = 0;
	while(1) {
		n++;
		flag = 0;
		for(i = 1; i <= 6; i++) {
			scanf("%d", &a[i]);
			if(a[i] > 0) {
				flag = 1;
			}
		}
		if(!flag) {
			break;
		}
		sum = 0;
		for(i = 1; i <=6; i++) {
			sum += a[i]*i;
		}
		if(sum %2 != 0) {
			printf("Collection #%d:\nCan't be divided.\n\n",n);
		} else {
			total = sum/2;
			memset(dp,0,sizeof(dp));
			for(j = 1; j <= 6; j++) {
				multi_pack(j,j,a[j]);
			}
			if(dp[total] == total) {
				printf("Collection #%d:\nCan be divided.\n\n",n);
			} else {
				printf("Collection #%d:\nCan't be divided.\n\n",n);
			}
		}
	}
	return 0;
}

我犯错的地方有zero_ont_pack函数中背包容量的上下限都是1,导致数组越下界。

猜你喜欢

转载自blog.csdn.net/dk1543100966/article/details/77267810