PAT (Advanced Level) Practice 1002 A+B for Polynomials (25 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85560865

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a​N1N​2aN​2 … N​Ka​N​K
​​
​​

where K is the number of nonzero terms in the polynomial, N​i and a​N​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:

3 2 1.5 1 2.9 0 3.2

//我刚开始以为指数也可以为小数……编了一大通,提交上去一堆错
//结果是,指数必为整数,系数必为一位小数

#include <cstdio>
#include <cstring>
#include <cmath>

double coe[1001] = { 0 };//多项式存储,下标为指数,存储数据为系数

int main()
{
	int n = 0, m = 0, cnt = 0, i = 0;//cnt为多项式个数
	int exp = 0;
	double t_coe = 0;
	scanf("%d", &n);
	for (i = 0; i < n; i++)
	{
		scanf("%d %lf", &exp, &t_coe);
		coe[exp] += t_coe;
	}
	scanf("%d", &m);
	for (i = 0; i < m; i++)
	{
		scanf("%d %lf", &exp, &t_coe);
		coe[exp] += t_coe;
	}
	i = 0;
	while (i <= 1000) if (coe[i++]) cnt++;//统计多项式的个数
	printf("%d", cnt);
	for (int i = 1000; i>=0; i--) 
	   if (coe[i]) 
	      printf(" %d %.1lf", i, coe[i]);//逆序打印,格式为保留一位小数
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85560865