1352: Max Sum

题目描述
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
输出
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
样例输入2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

样例输出Case 1:
14 1 4

Case 2:
7 1 6

#include<stdio.h>
#include<algorithm>
using namespace std;
int main(){
    int t;
    scanf("%d",&t);
    int q=1;
    while(t--){
         int n,k=0;
         scanf("%d",&n);
         int a[100010],b[100010];
         for(int i=0;i<n;i++)
         scanf("%d",&a[i]);
         int MAX=-1010;
         for(int i=0;i<n;i++){
         b[i]=max(a[i]+b[i-1],a[i]);
         if(b[i]>MAX){
         MAX=b[i];
         k=i;
     }
     }
     int sum=0,i,j;
     for(i=k;i>=0;i--){
             sum+=a[i];
             if(sum==MAX){
             j=i;
         }
     }
      printf("Case %d:\n",q);
      printf("%d %d %d\n",MAX,j+1,k+1);
      printf("\n");
      q++;
      }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43731933/article/details/85019041
今日推荐