HDU1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 291913    Accepted Submission(s): 69228

 

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6

用dp[i]表示以a[i]为end position的连续子序列的和的最大值。即dp[i]=max(a[i],dp[i-1]+a[i])。求出最大值Max后终点很容易得出,就是相应的dp[i]的下标。当最大值是负数时,起点和终点相等。当最大值非负时,起点为终点前连续的最后一次出现非负dp[i]的下标。

AC代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<cmath>
using namespace std;
int main()
{
    int T,dp[100001],a[100001],i,num,j=1;
	cin>>T;
	while(T--)
	{
		cin>>num;
		memset(dp,-1,sizeof(dp));
		memset(a,-1,sizeof(a));
		for(i=1;i<=num;i++)
		cin>>a[i];
		int i0=1,in=1,Max=a[1];
	    for(i=1;i<=num;i++)
		{
		   dp[i]=max(a[i],dp[i-1]+a[i]);
		   if(dp[i]>Max)
		   {
		   	    Max=dp[i];
		   	    i0=in=i;
		   }
		}
	    while(dp[i0]>=0) i0--;
	    if(i0<in) i0++;
		cout<<"Case "<<j++<<':'<<endl;
		cout<<Max<<' '<<i0<<' '<<in<<endl;
		if(T>0) cout<<endl;//注意格式 
	} 
}

猜你喜欢

转载自blog.csdn.net/qq_40889820/article/details/81273896