【DP】Max Sum

描述

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

输入

The first line of the input contains an integer T(1<=T<=25) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

输出

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

样例输入

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

样例输出

Case 1:
14 1 4

Case 2:
7 1 6

提示

Huge input, scanf is recommended.
分析:最大子段和,注意输出格式。
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int a[100002];
int T;
cin>>T;
for (int i=1;i<=T;i++)
{
int n;
cin>>n;
int sum=0,ans=-1e9,st=0,lt,k=1;
for (int j=0;j<n;j++)
{
cin>>a[j];
}
for (int j=0;j<n;j++)
{
sum+=a[j];
if (sum>ans)
{
ans=sum;
st=k;
lt=j+1;
}
if (sum<0)
{
sum=0;
k=j+2;
}
}
cout<<“Case “<<i<<”:”<<endl;
cout<<ans<<’ ‘<<st<<’ '<<lt<<endl;
if (i!=T) cout<<endl;
}
return 0;
}

发布了65 篇原创文章 · 获赞 0 · 访问量 1330

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/103982799