Max Sum HDU - 1003

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/liar771/article/details/54136875

Given a sequence a 1,a 2,a 3......a n, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
 
 

题意:给一串数,求最大的连续子串的和,并打印起点和终点。

坑里带坑,无语了。

本题用动态规划,假设前面有长度为n-1的子串和为sum,如果sum<0,那么下一个数没有必要算作前一个子串的一部分,重开一个子串。

注意序列全是负数时。

每次子串更新时,记录开始点,遇到最大值,更新开始点,和最大值的点。

#include<stdio.h>
#include<math.h>
#include<ctype.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int t,n,a[1000001],i,j;
int main()
{
    int t,n,i,a[100001],e=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int maxn,start1=1,start2=1,end1=1;
        scanf("%d",&a[1]);
        for(i=2,maxn=a[1];i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i-1]>=0)a[i]+=a[i-1];
            else start2=i;
            if(a[i]>maxn)
                maxn=a[i],end1=i,start1=start2;
        }
        if(e>=2)
            printf("\n");
        printf("Case %d:\n%d %d %d\n",e,maxn,start1,end1);
        e++;
    }
}


猜你喜欢

转载自blog.csdn.net/liar771/article/details/54136875