hdu 1003 Max Sum

【题目】

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 287199    Accepted Submission(s): 68204

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
 
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output
 
  
Case 1: 14 1 4 Case 2: 7 1 6

【题解】

来来来补题了

连续最大子序列。由于元素范围为[-1000,1000],设置ans初始值-inf,sum<0时重新从下一个元素开始计算一段子序列。

【代码】

#include<iostream>
using namespace std;
const int inf=0x3f3f3f3f;
int a[100005];
int ans,l,r;
void dfs(int n)
{
    int sum=0,p=1,q=1;
    for(int i=1;i<=n;i++)
    {
        sum+=a[i];
        if(sum>=ans)
        {
            q=i;
            ans=sum;
            l=p,r=q;
        }
        if(sum<0)
        {
            sum=0;
            p=i+1,q=i+1;
        }
    }
}
int main()
{
    int t,i,j,n;
    cin>>t;
    for(j=1;j<=t;j++)
    {
        if(j>1)
           cout<<endl;
        cin>>n;
        for(i=1;i<=n;i++)
            cin>>a[i];
        ans=-inf,l=1,r=1;
        dfs(n);
        cout<<"Case "<<j<<":"<<endl;
        cout<<ans<<' '<<l<<' '<<r<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41117236/article/details/80874754