hdu1003Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 283296    Accepted Submission(s): 67285


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
  
Case 1: 14 1 4 Case 2: 7 1 6

思路:找出和最大的子段,首先想到的是枚举,枚举的方法是,分别将数串中的每一个数作为子段的第一位数,然后子段长度依次递增。例如:
(2,-3,4,-1)这个数串枚举的所有情况为:
以2作为子段的第一位:     2,(2,-3),(2,-3,4),(2,-3,4,-1)。
以-3作为子段的第一位:  -3,(-3,4),(-3,4,-1)。
以4作为子段的第一位:     4,(4,-1)。
以-1作为子段的第一位:  -1 。

从枚举的过程中发现:
当前子段和的值为负值时,就没必要再往下进行,而应将下一位数作为子段的第一位。

代码;

#include <stdio.h>
int main()
{
    int i,j,t,n,number,sum,start,end,p,max;
    scanf("%d",&t);
    j=t;
    for(j=1;j<=t;j++)
    {
        scanf("%d",&n);
        max=-1010;
        sum=0;
        p=1;
        for(i=1;i<=n;i++)
        {
           scanf("%d",&number);
           sum=sum+number;
           if(sum>max)
           {
               max=sum;
               start=p;
               end=i;
           }
           if(sum<0)
           {
               sum=0;
               p=i+1;
           }
        }
        printf("Case %d:\n%d %d %d\n",j,max,start,end);
        if(j!=t)
            printf("\n");
    }
    return 0;
}

如果sum>max,则把sum给max

如果sum<0,则没必要往下进行,令sum=0,p=p+1,江夏一位数作为字段的第一位,重头来

隐含的如果sum<0,则继续输入,sum继续加,但是max 不变,只要前面的和是个正数,就还有继续加的价值,不管怎么样都是正的,直到加到sum>max或者sum<0,或者到最后全都输完了也还是不大不小,即既不干掉max,也不被淘汰出局,那输出的还是原来的max,也许会问怎么保证讲下一位作为第一位不会比这个长吗?答案是不会,因为下一位前面的这段是正的,所以不管怎么说加一个正数只会比不加上这段要大而已

猜你喜欢

转载自blog.csdn.net/nanfengzhiwoxin/article/details/80274622