A - Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8
题目大意:给你个m,n,给你n个数,要求你找到m段相加起来是最大的数。

题解:h[i][j]为在包含第i个元素的时候,有j个段的最大和而且第i个元素和h[i-1][j]的最后一段为连续的,g[i][j]为不一定包含第i个元素的,有j个段的最大和的情况而且第i个元素和g[i-1][j]的最后一段是不连续的,假设这两个二维数组在第i个元素的时候已经满足在第i个元素之前这段的所有条件,就是满足有j段和在第i个元素之前的一段中为最大的和,所以我们到第i个元素的时候,看看是否选择这第i个元素,所以就写出所有可能的情况。

h[i][j]=max(h[i-1][j],g[i-1][j-1])+w[i](w[i]为每一个元素的值),g[i][j]=max(h[i][j],g[i-1][j]);

因为二维数组空间太大了,所以就用一维数组,h[j]=max(h[j],g[j-1])+w[i],g[j]=max(h[j],g[j]);

代码:

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

long long int g[10000008],h[10000008];
int i[10000008];

int main()
{
    int a,b,c,n,j;
    while(~scanf("%d %d",&c,&a))
    {
    for(b=1;b<=a;b++)
        scanf("%d",&i[b]);
    for(b=1;b<=c;b++)
        g[b]=h[b]=-9999999999;
    for(n=1;n<=a;n++)
    {
        for(j=c;j>=1;j--)
        {
            h[j]=max(h[j],g[j-1])+i[n];
            g[j]=max(g[j],h[j]);
        }
    }
    printf("%lld\n",g[c]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/The_city_of_the__sky/article/details/81771496