Max Sum

Problem description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

经典DP 不解释!

代码如下:

#include<cstdio>

int main()
{
    int num[100000];
    int n,t,cur,before,max,s,e,ca=1;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&t);
        for(int i=1;i<=t;i++)
            scanf("%d",&num[i]);
        max=before=num[1];
        s=e=cur=1;
        for(int i=2;i<=t;i++)
        {
            if(before<0)
            {
                before=num[i];  
                cur=i;
            }
            else before+=num[i];
            if(max<before)
            {
                max=before;
                s=cur;
                e=i;
            }
        }
        printf("Case %d:\n%d %d %d\n",ca++,max,s,e);
        if(n) printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hjq_xidian/article/details/52629865