Max Sum (hdu 1003)

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

题解:就是求连续序列的最大和,遍历时不断比较更新下标即可。

代码如下:

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <ctime>
#define maxn 1007
#define N 100005
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define eps 0.000000001
#define read(x) scanf("%d",&x)
#define put(x) printf("%d\n",x)
#define Debug(x) cout<<x<<" "<<endl
using namespace std;
typedef long long ll;


int main()
{
    int t,cas=1;
    cin>>t;
    while(t--)
    {
        int n,a;
        cin>>n;
        int sum=0;
        int start,end,temp=1,max1=-INF;
        for(int i=0;i<n;i++)
        {
            cin>>a;
            sum+=a;
            if(sum>max1)
            {
                max1=sum;
                start=temp;
                end=i+1;
            }
            if(sum<0)
            {
				sum=0;
				temp=i+2;
			}
        }
        cout<<"Case "<<cas++<<":"<<endl;
        cout<<max1<<" "<<start<<" "<<end<<endl;
        if(t!=0)
            cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/baiyi_destroyer/article/details/81199035