NYOJ 1003 MAX SUM

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/mml5211314/article/details/50603112

Max Sum



Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
  
Case 1: 14 1 4 Case 2: 7 1 6
//求一组数的最大和,做法是判断当前的和加上下一个数的和是否小于下一个数,之后适情况作出处理方法

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	int a[100010];
	int m,s,e,p,ms,ts,k=0,i;
	scanf ("%d",&n);
	while (n--)
	{
	
		k++;
		scanf ("%d",&m);
		for (i=0;i<m;i++)
		scanf ("%d",&a[i]);
		s=e=p=0;
		ms=ts=a[0];
		for (i=1;i<m;i++)
		{
			if (ts+a[i]<a[i])
			{
				ts=a[i];
				p=i;
			}
			else
			{
				ts+=a[i];
			}
			if (ts>ms)
			{
				ms=ts;
				s=p;
				e=i;
			}
			
		}
		printf ("Case %d:\n",k);
		printf ("%d %d %d\n",ms,s+1,e+1);
		if (n)
		printf ("\n");
	 } 
	return 0;
}

















猜你喜欢

转载自blog.csdn.net/mml5211314/article/details/50603112
今日推荐