Max sum(简单dp)

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

算前面的最大值和加上现在之后 看代码号理解

#include <iostream>
#include <string.h>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include <map>
#include<set>
#include<cstdio>
using namespace std;
int a[100005];
int main()
{
    int t;
    scanf("%d",&t);
    int flag=0;
    for(int num=1;num<=t;num++)
    {
        if(flag)
            printf("\n");
        else
        {
            flag=1;
        }
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int sum=0,maxn=-9999999,ji=0,st=0,en=0;
        for(int i=0;i<n;i++)
        {
            sum+=a[i];
            if(sum>maxn)
            {
                maxn=sum;
                st=ji;
                en=i;
            }
            if(sum<0)
            {
                sum=0;
                ji=i+1;
            }
        }
        printf("Case %d:\n",num);
        printf("%d %d %d\n",maxn,st+1,en+1);
//        for(int i=st;i<=en;i++)
//        {
//            printf("%d ",a[i]);
//        }
//        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43372531/article/details/85984569