HDU 2669 Romantic【扩展欧几里得】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/82934128

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

题解:

扩展欧几里得定理:对于任意整数  a, b,都存在 x, y 使得 ax + by = gcd(a, b)。

对于一般的方程 ax + by = c,它有解当且仅当 d|c,而本题的 c 等于1,所以d也要等于1才有解。无解输出 “sorry”。并且要求的解 x 必须大于等于0,所以又需要用到通解公式: x = (c/d)x + (b/d)k, y = (c/d)y - (a/d)k, k 为任意整数。

#include <iostream>
#include <cstdio>
#define ll long long
using namespace std;

int exgcd(int a, int b, int &x, int &y){
    if(b == 0){
        x = 1, y = 0;
        return a;
    }
    int d = exgcd(b, a%b, x, y);
    int z = x;
    x = y, y = z - (a/b) * y;
    return d;
}
int main()
{
    int a, b;
    while(cin >> a >> b){
        int x, y;
        int d = exgcd(a, b, x ,y);
        if(d != 1){
            cout << "sorry" << endl;
        }else{
            while(x < 0){
                x += b;
                y -= a;
            }
            cout << x << " " << y << endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/82934128