HDU 2669 - Romantic(线性模方程/exgcd板子)

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9860    Accepted Submission(s): 4189


 

Problem Description

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

 

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)

 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

 

Sample Input

 

77 51

10 44

34 79

 

Sample Output

 

2 -3

sorry

7 -3

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define LL long long
#define clr(a) memset(a,0,sizeof(a))

const int MAXN = 1e5+10;
const int INF = 0x3f3f3f3f;
const int N = 1e6;

LL a,b,x,y;

LL gcd(LL a,LL b){
    return b == 0 ? a : gcd(b , a % b);
}
LL exgcd(LL a,LL b,LL &x,LL &y){
    if(!b){
        x = 1;y = 0;
        return a;
    }
    LL r = exgcd(b,a % b,x,y);
    LL t = x;
    x = y;
    y = t - a / b * y;
    return r;

}

int main(){
    while(scanf("%lld%lld",&a,&b)!=EOF){
        LL c = exgcd(a,b,x,y);
        if(c != 1){
            printf("sorry\n");
        }
        else {
            if(x < 0) x += b, y -= a;
            printf("%lld %lld\n",x,y);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/81566944