Romantic(扩展欧几里得)

题目:

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3
#include <iostream>
#include <stdio.h>
#include <string.h>
#define MAXN 1000005
#define LL long long
using namespace std;

LL exgcd(LL a, LL b, LL &x, LL &y) {
    if(b == 0) {
        x = 1;
        y = 0;
        return a;
    }
    else {
        LL d = exgcd(b, a % b, y, x);
        y -= a / b * x;
        return d;
    }
}

int main()
{
   LL a,b,x,y;
   while(scanf("%lld%lld",&a,&b)==2)
   {
       LL d=exgcd(a, b,x, y);
       if(d!=1)printf("sorry\n");
       else {
	while(x<=0) {
            x += b ;
            y -= a ;
    }
    printf("%lld %lld\n",x,y);
   }
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81294512