RSA——HDU1211(扩展欧几里得

Problem Description

RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

> choose two large prime integer p, q
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = m^e mod n

When you want to decrypt data, use this method :

M = D(c) = c^d mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.

 

Input

Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.

 

Output

For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.

 

Sample Input

 

101 103 7 11

7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239

 

Sample Output

 

I-LOVE-ACM.

 

Author

JGShining(极光炫影)

 

Source

杭电ACM省赛集训队选拔赛之热身赛

#include <map>
#include <set>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <vector>
#include <string>
#include <bitset>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
long long ju(long long a,long long d,long long n){
	long long s=a,sum=1;
	while(d){
		if(d&1){
			sum=sum*s%n;
		}
		s=s*s%n;
		d>>=1;
	}
	return sum;
}
void gcd_(long long a,long long b,int &x,int &y){
	if(b==0){
		x=1;
		y=0;
		return ;
	}
	gcd_(b,a%b,x,y);
	long long temp=x;
	x=y;
	y=temp-a/b*y;
	return ;
}
long long inv(long long s,long long d){
	int x,y;
	gcd_(s,d,x,y);
	return (x%d+d)%d;
}
int main(){
	long long p,q,e,l;
	while(scanf("%lld %lld %lld %lld",&p,&q,&e,&l)!=EOF){
		long long fn=(p-1)*(q-1);
		long long n=p*q;
		long long d=inv(e,fn);
		long long temp;
		while(l--){
			scanf("%lld",&temp);
			printf("%c",(int)ju(temp,d,n)%n);
		}
		printf("\n");
	}
} 

猜你喜欢

转载自blog.csdn.net/doublekillyeye/article/details/82597897