HDU2669 拓展欧几里得

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13588    Accepted Submission(s): 5776


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 
Sample Input
77 51 10 44 34 79
 
Sample Output
2 -3 sorry 7 -3
 
 
AC代码
#include<bits/stdc++.h>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
void exgcd(int a,int b,int&d,int & x,int &y){
    if(b==0){d=a;x=1;y=0;}
    else{exgcd(b,a%b,d,y,x);y-=(a/b)*x;}
}
int main(){
    int x=0,y=0;int d=0;
    int a,b;
    while(cin>>a>>b){
        exgcd(a,b,d,x,y);
        if(d!=1)cout<<"sorry\n";
        else {
            while(x<0){
                x+=b/1;y-=a/1;
            }
            printf("%d %d\n",x,y);
        }
        
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/m2364532/p/12388605.html