HDU-2669-Romantic (扩展欧几里得算法)

版权声明:欢迎评论与转载,转载时请注明出处! https://blog.csdn.net/wjl_zyl_1314/article/details/84707666

原题链接:
http://acm.hdu.edu.cn/showproblem.php?pid=2669
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy Xa + Yb = 1. If no such answer print “sorry” instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.
Sample Input
77 51
10 44
34 79
Sample Output
2 -3
sorry
7 -3
题意:
输入a,b,要求找出满足ax+by=1等式的其中x最小的那一组解。
题解:
利用扩展欧几里得算法,如果a和b的最小公约数是1,则一定有解,再将其中x最小的一组解输出。
如果不是1,则sorry。
附上AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
int exgcd(int a,int b,int &x,int &y)//扩展欧几里得算法
{
    if (b==0)
    {
        x=1,y=0;
        return a;
    }
    int q=exgcd(b,a%b,y,x);
    y-=a/b*x;
    return q;
}
int main()
{
    int a,b,x,y;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        if(exgcd(a,b,x,y)==1)
        {
            while(x<0)//调整至x最小的非负数
            {
                x+=b;
                y-=a;
            }
            printf("%d %d\n",x,y);
        }

        else
            printf("sorry\n");
    }
    return 0;
}

欢迎评论!

猜你喜欢

转载自blog.csdn.net/wjl_zyl_1314/article/details/84707666