Hdu 2669 Romantic 扩展欧几里得

Problem Description

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

Sample Input

 

77 51

10 44

34 79

Sample Output

 

2 -3

sorry

7 -3

 代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
ll a,b;
ll Extend (ll A,ll B,ll& X,ll& Y)
{
    if(B==0)
    {
        X=1; Y=0;
        return A;
    }
    else
    {
        ll ans,temp;
        ans=Extend (B,A%B,X,Y);
        temp=X;
        X=Y;
        Y=temp-(A/B)*Y;
        return ans;
    }
}
int main()
{
    while (scanf("%lld%lld",&a,&b)!=EOF)
    {
        ll x,y;
        ll Gcd=Extend(a,b,x,y);
        if(Gcd!=1)
            printf("sorry\n");
        else
        {
            x=(x%b+b)%b;
            y=(1-a*x)/b;
            printf("%lld %lld\n",x,y);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83006209