HDU-2669 Romantic(扩展欧几里德)

                                             Romantic

                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                             Total Submission(s): 10350    Accepted Submission(s): 4416

Problem Description

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei (
以上全是废话)

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51

10 44

34 79

Sample Output

2 -3

sorry

7 -3

http://acm.hdu.edu.cn/showproblem.php?pid=2669

题意:

输入a和b, 然后让你求X和Y满足此表达式X*a + Y*b = 1。并且输出X最小正整数的一组,Y可以为负数。如果找到一组X,Y,则输出sorry

思路:

利用扩展欧几里德求出一个X,Y。然后找X为最小正整数的一组。

X = X0 + kb

Y = y0 - ka;

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

long long gcd(long long a, long long b, long long& x, long long& y)
{
	if(a == 0 && b== 0)	
		return -1;
	if(b == 0){
		x = 1;
		y = 0;
		return a;
	}
	long long d = gcd(b, a%b, y, x);
	y -= a/b*x;
	return d;
}
int main()
{
	long long a, b; 
	while(scanf("%lld %lld", &a, &b)!=EOF) {
	  	long long x, y;
	  	long long d = gcd(a, b, x, y);
	  	if(d != 1)
			cout << "sorry" << endl;
	  	else {

	  		while(x <= 0) {
	  			x += b;
	  			y -= a;
			}
	  		cout << x<< " " << y << endl;
		  }
			
	}
		
	return 0;
 }

 

猜你喜欢

转载自blog.csdn.net/Sclong0218/article/details/83240097